Due to SPAM attacks, new members must be approved before posting.  Please email when registering and your account will be approved.

Main Menu

Range Check Errors in 6.0.1

Started by Ed_TBEP, August 12, 2010, 07:19:25 AM

Previous topic - Next topic


I have tried various scales (3m, 5m, 10m pixel) and clipped areas (entire Tampa Bay region, specific bay segments) in attempt to run SLAMM. At first I was getting out of memory errors, but as I've reduced the raster file sizes, I now get range check errors. I get past the point of "Set Attributes" and the maps drawing, but as soon as I try to execute the model I receive the "Range check error." I'm stumped at this point--my total memory use is <1GB with my current run and the file check doesn't seem to be showing any errors. Anybody have any suggestions of what to try to get the SLAMM model running???


This has happened to me before, many months ago. I don't remember exactly what it was that was causing it, but I think it has to do with alignment of your input rasters.  I *think* that all your input layers have to be exactly the same extent or you'll get this error. Good luck!


Jonathan S. Clough

Hmm.  I thought that this problem had been resolved...  A range-check error is definitely some sort of programming error.  Try pressing the "count" button on the SLAMM File Setup before running the simulation.  This may help.  (However, I thought I had fixed that particular problem.)  I'll try to track it down as well. 

If possible, can you send me the files in question that cause this problem and I'll reproduce it and fix the problem.  If you email me directly I will send you my FTP information if that is required.  Zipping these ascii inputs also reduces file size dramatically.

-- Jonathan

Jonathan S. Clough

ALSO, I really recommend running on a 64 bit OS with >4GB of RAM as that allows the software to use a 4GB memory footprint.   (Hopefully 64 bit SLAMM will eventually appear in which even that 4GB limit is removed.)


I've created all the rasters using the same extent and cell counts, as I first suspected this may be the problem--but I still get the errors regardless of the cell size I try to employ.

I've also used the "Count" button before running the simulation/set map attributes, but still get the errors. I haven't tried a 64-bit OS system >4gb ram yet, though.

Jonathan, I sent an email to you directly to get the FTP details. Thanks again for your help.

Evan Larson

I couldn't reproduce the error in 64-bit Windows 7.  In 32-bit Windows XP I was able to produce an "out of memory" error during SLAMM execution, but not the "range check" error you're receiving.



Thanks Evan.

I will try to execute the run on a 64-bit Win 7 system and post my results this week.


I just tried to execute a run on a Win 7 64-bit system (4gb ram), but I am still getting the range check error. The same deal as on a Win XP 32bit system, I can draw the map, run an elevation analysis, but when I try to execute a run, I immediately get a range check error dialog. I feel like I'm overlooking something simple, but can't figure out what will get a test run going with my input files... Any suggestions???


Well, I decided to start over from scratch instead of loading my canned simulation file. I re-entered all my site parameter characteristics and for two accretion rates I chose to use only values rounded to the tenth decimal. I also chose fewer scenarios to run, and voila...SLAMM is currently executing...

Not sure what I might have changed to prevent the range check error from occurring, but it is at least running through the A1B Max scenario right now!!!

Jonathan S. Clough

Sorry that we were unable to get the canned file to crash here.  Makes me wonder if I somehow had fixed something in-between the latest release and the working version we're currently working with.  It doesn't ring a bell but I'll check on that to see if that is the case to ensure that this type of pain does not occur again.  -- Jonathan