Due to SPAM attacks, new members must be approved before posting.  Please email when registering and your account will be approved.

Main Menu

Floating point error

Started by andybell, September 17, 2019, 04:01:03 PM

Previous topic - Next topic


I have just installed SLAMM 6.7 on my laptop (8GB Ramm on windows 10)
I am trying to run a model that I have downscaled from 2m to 10m resolution, but get an error when it reaches 6% in reading the site characteristics. The error reads "Invalid Floating Point Operation". The error comes up when the 6% progress is met

Any clues what might cause this?
Many thanks in advance



Just as an update; I used the sample data and the programme works fine. Therefore it is an issue with my data.
The *.ASC files check OK within SLAMM and they load without issue in QGIS and ArcGIS.

Can anyone advise what are the problems within data that might trigger the "Floating Point" error?

Much obliged


A further update.
The data works in version 6.0.1 at the 10m resolution level but runs out of memory at the 2m resolution.

It would nice to run 6.7 version to get the carbon module.

Kind regards

Jonathan S. Clough


The 64-bit version of the software should be able to accommodate nearly any map size -- the limitations are the memory of the machine (and there are also practical limitations in terms of how long it takes to load and run simulations.)   We have found the maximum size that is reasonably practicable to run is approximately 26 GB of memory (~250 million cells) but that obviously requires 32 GB of memory or more. 

Note the memory utilization in GB is given in the SLAMM File setup window and different optimization options are available a the bottom of the screen. 

e.g. "Cells to Track 7,169,539, memory utilization in GB 0.7478"

Are you saying that data can be input at 10m resolution in 6.0.1 but that 6.7 crashes with the same data set?  Have you tried converting the data to binary using the binary button?  This significantly optimizes input/output and may shed light on the problem.  If you cannot solve the problem, you can send me the data files and I can look at it, but I'm afraid I have not been very responsive in terms of loading other people's data lately.  Sorry that the software is not giving you a more helpful error message. 

I hope your problem resolves shortly.


Hi Johnathan,
thanks for the helpful reply.

Yes, the same 10m resolution data set works in 6.0 but not in 6.7
I tried the 2m resolution set in 6.0 and it went to write to disc then crashed...unsurprisingly; they are pretty big files.

I have ordered more memory for the laptop and will try the binary option for both datasets in 6.7 as you advise.

If this doesn't work I will zip up the 10m data for you to diagnose stepwise in 6.7, but that will be my last option knowing how busy you are.
All the best