September 22, 2021, 11:40:44 PM

News:

Due to SPAM attacks, new members must be approved before posting.  Please email jclough@warrenpinnacle.com when registering and your account will be approved.


Matching extents

Started by HeatherAnn, November 18, 2009, 12:10:58 PM

previous topic - next topic
Go Down

HeatherAnn

For our project we are using the SLAMM modeling tool to analyze sea level rise in the Columbia River.
I found slight discrepancy in xllcorner, yllcorner, which I am assuming is because our data comes from different sources.  I am having problems getting the extent to match exactly.
So my question is do you know of a way to manually reset the extent of a raster?
Since I am using LiDAR for the DEM this has caused the ASCII files to be very large- so large that they cannot be opened through most editing programs. Is there a way to manually reset the extent in either an Arc application or grass?

Dean

Hi HeatherAnn,

Yes, the extents have to be exactly the same for all model inputs. You can do this in Raster Calculator in ArcMap. Go the the Options in the Spatial Analyst extension toolbar and set the "snap extent to" and "analysis cell size" settings to the same raster for all input rasters, then recreate the ascii files.  I always use my DEM for these settings, once I clip the the site I'm analyzing, so that all the other rasters (nwi, slope, etc) are the same dimensions.  I'm sure there must be other ways to do it though, so others may chime in here.

Good luck,
Dean

Jonathan S. Clough

There is another potential solution to this problem if the offset is extremely small.

If you are working with a UTM projection, so you can see the difference between the lower left corner in meters, you can potentially force the lower left corner to be the same between the two input text files.  (This works with other projections as well though you'll have to do some math to determine the extent of the horizontal error.)

For example, I have received data inputs which were horizontally off-set by well less than 1cm when looking at 30meter cells.  Simply editing the "ASC format" text files so that they have the same lower left corner will solve that problem without introducing any relevant error to model results.

Go Up