June 18, 2019, 11:41:09 PM

News:

Due to SPAM attacks, new members must be approved before posting.  Please email jclough@warrenpinnacle.com when registering and your account will be approved.


SLAMM 6.7 compile error

Started by hachinamio, February 27, 2019, 04:59:12 AM

previous topic - next topic
Go Down

hachinamio

Dear all,
I need to modify some codes, but when I compile the project it said that (I used RAD Studio 10.3):

Checking project dependencies...
Compiling slamm6.dproj (Debug, Win64)
dcc64 command line for "slamm6.dpr"
  c:\program files (x86)\embarcadero\studio\20.0\bin\dcc64.exe -$O- -$A- -$J+ -$R+ -$Q+ --no-config -M -Q -TX.exe -AWinTypes=Windows;WinProcs=Windows;
  DbiTypes=BDE;DbiProcs=BDE;DbiErrs=BDE;Generics.Collections=System.Generics.Collections;Generics.Defaults=System.Generics.Defaults;
  WinTypes=Winapi.Windows;WinProcs=Winapi.Windows;DbiTypes=BDE;DbiProcs=BDE;DbiErrs=BDE -DDEBUG -ISVOSource;tdbf-xe4;OpenGL/;OpenGL/Framework/;
  "c:\program files (x86)\embarcadero\studio\20.0\lib\Win64\release";C:\Users\Dal_PIV2\Documents\Embarcadero\Studio\20.0\Imports;"c:\program files
  (x86)\embarcadero\studio\20.0\Imports";C:\Users\Public\Documents\Embarcadero\Studio\20.0\Dcp\Win64;"c:\program files
  (x86)\embarcadero\studio\20.0\include" -LEC:\Users\Public\Documents\Embarcadero\Studio\20.0\Bpl\Win64
  -LNC:\Users\Public\Documents\Embarcadero\Studio\20.0\Dcp\Win64 -NSData.Win;Datasnap.Win;Web.Win;Soap.Win;Xml.Win;Vcl;Vcl.Imaging;Vcl.Touch;
  Vcl.Samples;Vcl.Shell;System;Xml;Data;Datasnap;Web;Soap;Winapi;FMXTee.Editor.Series.Bar;FMXTee.Editor;VCLTee;System.Win;Bde; -OSVOSource;tdbf-xe4;
  OpenGL/;OpenGL/Framework/;OpenGL/;OpenGL/Framework/;c:/programming/FastMM4/;"c:\program files (x86)\embarcadero\studio\20.0\lib\Win64\release";
  C:\Users\Dal_PIV2\Documents\Embarcadero\Studio\20.0\Imports;"c:\program files (x86)\embarcadero\studio\20.0\Imports";
  C:\Users\Public\Documents\Embarcadero\Studio\20.0\Dcp\Win64;"c:\program files (x86)\embarcadero\studio\20.0\include" -RSVOSource;tdbf-xe4;OpenGL/;
  OpenGL/Framework/;OpenGL/;OpenGL/Framework/;c:/programming/FastMM4/;"c:\program files (x86)\embarcadero\studio\20.0\lib\Win64\release";
  C:\Users\Dal_PIV2\Documents\Embarcadero\Studio\20.0\Imports;"c:\program files (x86)\embarcadero\studio\20.0\Imports";
  C:\Users\Public\Documents\Embarcadero\Studio\20.0\Dcp\Win64;"c:\program files (x86)\embarcadero\studio\20.0\include" -USVOSource;tdbf-xe4;OpenGL/;
  OpenGL/Framework/;"c:\program files (x86)\embarcadero\studio\20.0\lib\Win64\release";C:\Users\Dal_PIV2\Documents\Embarcadero\Studio\20.0\Imports;
  "c:\program files (x86)\embarcadero\studio\20.0\Imports";C:\Users\Public\Documents\Embarcadero\Studio\20.0\Dcp\Win64;"c:\program files
  (x86)\embarcadero\studio\20.0\include" -V -VN -VR -$M16384,16777216 -GD -NBC:\Users\Public\Documents\Embarcadero\Studio\20.0\Dcp\Win64
  -NHC:\Users\Public\Documents\Embarcadero\Studio\20.0\hpp\Win64  slamm6.dpr   
[dcc64 Error] global.pas(1946): E2003 Undeclared identifier: 'LowPart'
[dcc64 Error] global.pas(1947): E2003 Undeclared identifier: 'HighPart'
[dcc64 Fatal Error] F2063 Could not compile used unit 'global.pas'
Failed
Elapsed time: 00:00:00.6


I did some searches on google but still couldn't find the address. Anyone knows this error please help me? Thank you very much.

Jonathan S. Clough

February 27, 2019, 07:38:20 AM #1 Last Edit: March 07, 2019, 06:52:43 AM by Jonathan S. Clough
Greetings.

You are using a different development platform than the model was created on.  Things have changed, see:

https://stackoverflow.com/questions/44227692/casting-with-tulargeinteger-in-delphi-10-2-tokyo-differ-from-previous-version

Looks like it should be a quick code fix if you'd like to make it.  Otherwise you should be able to download [Embarcadero Delphi XE3] as a licensed user of the more recent version.   [edit- fixed version required at this time]

Best regards-- Jonathan

hachinamio

Dear Jonathan,

Thank you very much. I have tried your solutions, as well as tried the older version of Delphi (Delphi XE8 - I have used this one to modify SLAMM 6.2 without any problems), but I got another error related to overloaded. Please see the attached photo herewith. Do you know how to fix this problem? Thank you very much.

You cannot see attachments on this board.

Jonathan S. Clough

Sorry I misspoke.  The code must be compiled on Delphi XE3 -- my version is Embarcadero┬« Delphi┬« XE3 Version 17.0.4625.53395

I cannot port the code to other development platforms at this time.

Go Up