November 30, 2020, 02:31:43 PM

News:

Due to SPAM attacks, new members must be approved before posting.  Please email jclough@warrenpinnacle.com when registering and your account will be approved.


Range Check Error

Started by coreyjlange, February 13, 2014, 04:49:16 PM

previous topic - next topic
Go Down

coreyjlange

I'm having a "Range Check Error" showing up when I try to execute my model. I've looked at other previous threads on this topic, and they don't seem to help my problem. I've triple checked to make sure the the extent of all of my files are exactly the same and align perfectly. I'm running SLAMM 6.0. Could you give me any advise for why this error is coming up?

marco.propato

Assuming that all the rasters have same number of rows and columns, most probably the error is because you need to count again the cells to track (in the file setup window) before executing the model.

coreyjlange

I've tried that. I've done all 3 options for the cell tracking, and it's still giving me the "Range Check Error".

marco.propato

February 13, 2014, 08:19:17 PM #3 Last Edit: February 13, 2014, 08:26:08 PM by marco.propato
Uhmmm ...

then I would check if there is a problem with the values of some cells, e.g. wetland cover number should be either the assigned nodata value or an integer from 1 to 26.

Considering that you had previously a problem with the slope raster, I would start with it and make sure that the values are nodata or 0 to 90 degrees.  

Hope it helps.

Marco

coreyjlange

Ok, I've eliminated any values that could have been causing the problem, but the error message still persists... Any other suggestions?

Thanks

Jonathan S. Clough

Marco writes:

I have checked the project rasters. The main issue is that the project is really big. If you are tracking all cells the project size is 61 GB of RAM memory . This can be reduced 2.7 GB by not tracking blank cells and high elevations. However, if you try to open the map or executing with show maps on screen option selected, then you need at least 10 GB of memory (I did not get any error message except that the map was too big to open on my computer). This means that first you need at least  a 64-bit version of SLAMM (I can send you a copy if you want), and second you need enough RAM memory to support this project.

If your available RAM memory is not that big, then probably the best course of actions is to split the study area in more manageable sizes, eliminate the not useful areas full of no data and/or reduce the cell resolution (3 m is a pretty small cell size ...)

Go Up